Loading... Please wait...

Our Newsletter


Which R4 card support latest 3DS V5.1.0 console?

Posted on 6th Apr 2013 @ 3:55 AM

3DS V5.1.0-11 system update on April 6th

Nintendo upgraded 3DS (3DSXL) system to V5.1.0-11 E/U/J on April 6th. The new 3DS V5.1.0 update didn't block flashcard. Below is the change log

nintendo-3ds.jpg

 

  • It was said by nintendo that the update is mean't to fix errors with system updating that had been occurring in 5.0.0-11.
  • Nintendo can now push new apps without your allowance with spotpass, as seen with auto-added JAP region apps for eBooks and another misc app. (Although it's probable that they legally cannot push new updates on you(forcefully anyway) Just simply block online applications such as the eShop
  • Minor update
  • eShop additions
  • Blocks access to eShop without an update
  • All regions

Which R4 card can work on 3DS V5.1.0?

All flashcards which work on 3DS V5.0.0, can also work on latest 3DS (XL) V5.1.0-11 E/U/J system directly, no need any upgrade. It contains:

R4i Gold 3DS card and R4i Gold RTS card from r4ids.cn.

R4i SDHC 3DS card and R4i SDHC RTS card from r4i-sdhc.com.

Supercard DStwo from supercard.sc

R4i Dual Core card (2013 version) and R4isdhc RTS (2013 version) from r4isdhc.com

M3i Zero from m3adapter.com

EZ-flash from ezflash.com

R4i Gold Plus card from r4ids.com

R4iTT RTS card from r4itt.net

R4i-Gold Pro card from r4i-gold.com

R4i-Gold 3DS card from r4i-gold.eu