Loading... Please wait...

Our Newsletter


R4iTT and R4iTT 3DS card break Nintendo 3DS V2.2.0-4

Posted on 7th Nov 2011 @ 2:11 AM

Good news, r4itt.net released new update patch. By installing the patch, R4iTT and R4iTT 3DS card can work on Nintendo 3DS V2.2.0-4J console. It is the fourth flashcard which break latest 3DS V2.2.0-4. Other flashcards are: R4i Gold Plus card from r4ids.com, R4i RTS card from r4isdhc.com, R4i Gold 3DS card from r4ids.cn.

            r4itt-3ds-cart.jpg

3ds V2.2.0-4 upgrade patch for R4iTT 3DS (R4iTT Black)

This is 3DS V2.2.0-4 upgrade package, if your black R4itt 3DS can not run on 3DS V2.2.0-4 console, please use this patch to upgrade your black r4itt 3DS card by nds/dsl/dsi/dsill/dsixl/3ds for running on 3DS V2.2.0-4 console.       Download

3ds V2.2.0-4 upgrade patch for R4iTT card (R4iTT Purple)

This is 3DS V2.2.0_4 upgrade package, if your purple r4itt card can not run on 3DS V2.2.0-4 console, please use this patch to upgrade your R4iTT card by nds\dsl\dsi\dsill\dsixl\3ds for running on 3DS V2.2.0-4 console.                    Download